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FEATURES 
Simple power connection using USB connection and  

on-board LDO voltage regulators 
LDOs are easily bypassed for power measurements 
AC-coupled differential LVPECL SMA connectors 
SMA connectors for  

1 reference input 
1 PLL lock detect output 

Microsoft Windows®–based evaluation software  
with simple graphical user interface 

On-board PLL loop filter 
Easy access to digital I/O and diagnostic signals  

via I/O header 
Status LEDs for diagnostic signals 
USB computer interface 
Dip switch configurable for manual operation 
Software calculator provides flexibility, allowing programming 

almost any rational input/output frequency ratio 

 

GENERAL DESCRIPTION 
This user guide describes the hardware and software of the 
AD9552 evaluation board and includes detailed schematics and 
PCB layout artwork. The AD9552 evaluation board is a 
compact, easy to use platform for evaluating all features of the 
AD9552 oscillator frequency upconverter.  

The AD9552 is a fractional-N phase-locked loop (PLL) based 
clock generator designed specifically to replace high frequency 
crystal oscillators and resonators. The device employs a sigma-
delta (Σ-Δ) modulator (SDM) to accommodate fractional fre-
quency synthesis. The user supplies an input reference signal by 
connecting a single-ended clock signal directly to the REF pin 
or by connecting a crystal resonator across the XTAL pins. 

The AD9552 is pin programmable, providing one of 64 standard 
output frequencies based on one of eight standard input frequen-
cies. The device also has a 3-wire SPI interface, enabling the user 
to program custom input-to-output frequency ratios. 

The AD9552 relies on an external capacitor to complete the loop 
filter of the PLL. The output is compatible with LVPECL, LVDS, 
or single-ended CMOS logic levels, although the AD9552 is 
implemented in a strictly CMOS process. 
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Figure 1. AD9552 Evaluation Board 
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EVALUATION BOARD HARDWARE 
The following instructions are for setting up the physical 
connections to the AD9552 evaluation board.  

SETTING UP THE POWER AND PC CONNECTIONS 
Set up the power and PC connections as follows: 

1. Install the AD9552 evaluation software before connecting 
the evaluation board to your PC for the first time (see the 
Installing the Software section). Administrative privileges 
are required for installation. 

The AD9552 has the option of either being pin or register 
programmable. If the pin-programmable option is desired, 
then no software is needed to control the part. However, it 
is recommended to install the software because if it is not 
installed, the computer recognizes the evaluation board as 
new hardware and attempts to install drivers. 

2. Connect the USB cables to the evaluation board and the 
computer.  

The red LED labeled VBUS (CR5) on the AD9552 evaluation 
board should illuminate, and the USB STATUS LED should 
start blinking. If the USB STATUS LED is not blinking, 
ensure that the USB port on the PC is operational and that 
the USB cable is not damaged. 

3. If the Found New Hardware Wizard automatically 
appears when the evaluation board is connected, select 
Install the software automatically and then click Next.  

The Found New Hardware Wizard may appear twice, and 
a system restart may be required. 

Refer to the Evaluation Board Software section for details on 
running the AD9552 evaluation board software. 

SETTING UP THE SIGNAL CONNECTIONS 
After setting up the power and PC connections, use the 
following procedure to set up the signal connections: 

1. Connect an oscilloscope, spectrum analyzer, or other lab 
equipment to any of the J3 to J6 SMA connectors on the 
upper right side of the board. The output connectors are 
single ended. A 50 Ω termination should be placed on all 
enabled unused outputs. 

BYPASSING THE USB POWER SUPPLY 
The evaluation board can be configured to supply power to the 
AD9552 from an external power supply. Bypass the USB power 
supply as follows: 

1. Remove the F2 ferrite bead (located on the backside of 
the board). 

2. Connect a bench power supply to Pin 3.3V_1 INPUT of 
TB1 on the evaluation board. In addition, resistors on the 
evaluation board can be removed to further separate power 
supply connections to the AD9552. This is useful for 
measuring the AD9552 power consumption. Refer to the 
evaluation board schematics provided on the CD in the 
evaluation board kit (also available at www.analog.com) for 
further details. 

 

http://www.analog.com/
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EVALUATION BOARD SOFTWARE 
The instructions included in this section are for setting up the 
AD9552 evaluation board software.  

INSTALLING THE SOFTWARE 
Do not connect the evaluation board until the software 
installation is complete. To install the software, 

1. Insert the AD9552 evaluation software CD-ROM into a PC 
CD disc drive. 

2. Click My Computer, and then double-click the 
AD9552EV CD icon.  

A window opens showing the contents of the CD divided 
into four sections: data sheet, layout, schematic, and software. 
The readme.txt file contains a description of the CD-
ROM contents, as well as any last minute instructions or 
information. 

3. Double-click the Software folder, and then double-click 
AD9552Eval_Setup1.1.0.exe. Follow the installation 
instructions. The default location for the evaluation 
software is C:\Program Files\Analog Devices\AD9552  
Eval Software\. 

4. If there are any updates to the evaluation software on a 
supplemental CD or in the \Software\Updates folder, be 
sure to copy the new .exe file, as well as any setup files, to 
the default location. 

USING THE SOFTWARE 
After the evaluation software has been installed, you can run 
the software as follows: 

1. Power up and connect the evaluation board to the PC. 

2. Double-click AD9552 Eval Software to run the AD9552 
evaluation software.  

A hardware installation window appears. Depending on 
whether the evaluation board is found by the software, the 
text in this window is either light blue, indicating that the 
evaluation board is found, or red, indicating that the 
evaluation board cannot be found.  

3. If the evaluation board is found, click in the window when 
the Evaluation Software Ready message appears.  

The main window of the evaluation board software appears. 
Proceed to the Guide to Programming the AD9552 section 
for more details about using the software. 

4. If the evaluation board is not found, a dialog box appears 
that allows you to select an evaluation board to use while 
the software runs in standalone mode. Standalone mode is 
useful for viewing and generating register setup files. 

5. If the evaluation board is not automatically detected when 
it is connected, choose Select Evaluation Board from the 
I/O menu, and then select Ezssp-0, Ezssp-1, or Ezssp-2 (see 
Figure 2).  
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Figure 2. Select USB Device Window 
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GUIDE TO PROGRAMMING THE AD9552 
The AD9552 can be programmed via an SPI port or by setting 
the logic levels on the frequency select pins of the device. To 
program the device using the serial port, the evaluation board 
software must be installed. 

For pin programming, there are two options: manually use the 
dip switches or use the evaluation board software to override 
the settings of the dip switches and change the logic levels of the 
frequency select pins. Using the dip switches on the evaluation 
board to establish the logic levels on the pins allows the AD9552 
to power on with preset conditions. Alternatively, you can use 
the software to override the settings of the dip switches on the 
evaluation board and change the logic levels on the frequency 
select pins. 

USING AN SPI PORT 
After the evaluation software is installed and the evaluation 
board is connected to a PC and loaded with the software, the 
following procedure is used to configure and lock the PLLs.  

In this example, the crystal frequency is 26 MHz, and the 
output frequency is 622.08 MHz. 

1. Ensure that Jumper JMP3 is positioned for PC control. 
2. Verify that all five jumpers are in place on Connector P2. 
3. Set the S1, S2, and S3 switches high. Set the S4 switch 

setting to high, except for RESET, which must be set to low 
(RESET is an active high pin). 

These steps assume that the input signal is present, that the 
evaluation board has not been modified, and that the PLL loop 
filter is suitable for the application. However, this guide covers 
only simple PLL operation (that is, to start and run the PLL). 
For a detailed explanation of more advanced AD9552 features, 
see the AD9552 data sheet. In addition, see the Software 
Operation section. 

USING DIP SWITCHES (MANUAL CONTROL) 
The following procedure explains how the AD9552 can be pro-
grammed manually by using the dip switches on the evaluation 
board to set the logic levels of the frequency select pins.  

In this example, the crystal frequency is 26 MHz, and the 
output frequency is 622.08 MHz. 

1. Ensure that Jumper JMP3 is positioned for manual control. 

2. Verify that all five jumpers are removed on Connector P2. 

3. Set the positions of the S3 dip switches to high to indicate a  
26 MHz crystal is being used. 

4. Set the positions of the S2 Y5 and Y4 dip switches to high 
and the positions of the S1 Y3 and Y0 dip switches to 0100. 

5. Connect an oscilloscope, spectrum analyzer, or other lab 
equipment to any of the J3 to J6 SMA connectors on the 
upper right side of the board. 

6. Power the evaluation board by plugging it into the USB port. 

7. A frequency of 622.08 MHz should be observed on the 
OUT1 SMA connector. 

If another output frequency is desired, remove the USB port. 
Then change the dip switch settings, and reapply the USB 
port connection. 

After each dip switch setting, the AD9552 must be powered down 
by removing the USB cable to reprogram the AD9552. See the 
AD9552 data sheet for an explanation of pin programming. 

USING SOFTWARE TO OVERRIDE DIP SWITCHES 
(SOFTWARE CONTROL) 
The evaluation board software can be used to override the 
settings of the dip switches and apply a logic level to the 
AD9552 frequency selection pins. 

After the evaluation software is installed and the evaluation 
board is connected to a PC and loaded with the software, the 
following steps are used to configure and lock the PLLs.  

In this example, the crystal frequency is 26 MHz, and the 
output frequency is 622.08 MHz. 

1. Ensure that Jumper JMP3 is positioned for PC control. 

2. Verify that all five jumpers are in place on Connector P2. 

3. Set the S1, S2, and S3 dip switch positions to high. 

4. Select 26 MHz for the input frequency in the XTAL Input: 
box in the main window of the evaluation software (see 
Figure 3 and the Reference Input Boxes section for more 
information). 

5. Select 622.08 MHz for the output frequency in the Output 
Loop Config: box in the main window of the evaluation 
software (see Figure 3). 

6. A frequency of 622.08 MHz should be observed on the 
OUT SMA connector. 

These steps assume that the input signal is present, that the 
evaluation board has not been modified, and that the PLL loop 
filter is suitable for the application. However, these steps are 
appropriate only for simple PLL operation (that is, to set up and 
run the PLL). See the AD9552 data sheet for more information 
about the various AD9552 features. 

 

http://www.analog.com/AD9552
http://www.analog.com/AD9552
http://www.analog.com/AD9552
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SOFTWARE OPERATION 
The main window of the AD9552 evaluation board software is 
comprised of subsections that correspond to the major functional 
blocks of the AD9552 (see Figure 3). These subsections, most of 
which have their own window, are outlined in this section. From 
the main window, the window for each functional block can be 
accessed by clicking the appropriate box in the main window.  

When a subsection window closes after clicking OK, you may 
notice that the LOAD button on the main window starts 
blinking. This indicates that there are settings that have not 
been loaded to the AD9552 evaluation board. Click LOAD to 
load these settings to the evaluation board.  
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Figure 3. AD9552 Evaluation Software Main Window 
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MENU BAR OF MAIN WINDOW 
File Menu 

The File menu allows you to load a previously saved AD9552 
setup file or to save a new AD9552 setup file. A setup file (.stp) 
is a text file that contains the AD9552 register setup file, plus 
any evaluation board settings.  

To load a previously saved setup file, select Load Setup from 
the File menu. Note that you must still perform a VCO 
calibration. Alternatively, to save a new setup file, select Save 
Setup from the File menu.  

To exit the evaluation software, select Exit from the File menu. 
However, note that no checking is done to ensure that the 
existing setup is saved. 

I/O Menu 

The AD9552 evaluation system allows one PC to control 
multiple evaluation boards. The Select USB Device window, 
accessed by choosing Select Evaluation Board from the I/O 
menu, allows you to select which evaluation board the software 
controls (see Figure 4). Click Refresh List to detect a recently 
connected evaluation board. 
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Figure 4. Select USB Device Window 

Selecting Configure Serial Port from the I/O menu allows you 
to control how the USB controller interacts with the AD9552 
serial port (see Figure 5) by configuring Register 0x00 (shown 
as 00H in Figure 7). 
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Figure 5. Serial Port Configuration Window 

View Menu 

The Debug window, accessed by selecting Debug Window 
from the View menu, allows you to write and read registers 
directly and to force the various configuration pins high or low 
(see Figure 6). 
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Figure 6. Debug Window 

The Register Map Debug window, accessed by selecting 
Register Debug Window from the View menu, allows you to 
write and read registers (see Figure 7).  
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Figure 7. Register Map Debug Window 
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Help Menu 

Selecting Help from the Help menu opens the About 
AD9551_AD9552 Evaluation Software window, which 
contains information such as revision number, region 
information, and contact information. 
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Figure 8. AD9552 Evaluation Software Window 

BUTTON BAR OF MAIN WINDOW 
The buttons described in this section provide easy access to 
common features. 

Load and Save 

Clicking Load and Save allows you to load and save an AD9552 
setup file. A setup file (.stp) is a text file that contains the AD9552 
register setup file, plus any evaluation board settings. 

Update 

Clicking Update toggles the I/O update bit (Register 0x05, Bit 0) of 
the AD9552. 

Reset 

Clicking Reset resets the evaluation board and restores the 
AD9552 to its default power-up state. In addition, clicking 
Reset enables the VCO calibration function by writing the 
enable VCO calibration bit. 

USING SOFTWARE TO CONTROL THE 
FUNCTIONAL BLOCKS OF THE AD9552 
The AD9552 evaluation software contains subsections that 
correspond to the major functional blocks of the AD9552. 
These subsections, most of which have their own window, are 
described in this section.  

You can access each window by clicking Click for Details in the 
appropriate subsection box of the main window. 

Most subsection boxes in the main window have a check box 
labeled SPI. If this box is selected, the software allows serial 

port writes when conditions are changed in the corresponding 
subsection window. 

When a subsection window closes after clicking OK, you may 
notice that the LOAD button on the main window starts 
blinking. This indicates that there are settings that have not 
been loaded to the AD9552 evaluation board. Click LOAD to 
load these settings to the evaluation board.  

Reference Input Boxes 

The reference input boxes, which are labeled Reference Input:  
and XTAL Input: in the main window, allow you to select an 
input frequency for the external reference input (J1 to REF) or 
the XTAL frequency. 

Crystal Control 

Clicking Click for Details in the Xtal Control box of the main 
window accesses the Xtal window (see Figure 9 for an example 
of the crystal control window).  

If a crystal frequency is chosen that is less than 16 MHz, the 
doubler is automatically enabled and controlled internally from 
the AD9552. 
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Figure 9. Crystal Control Window 
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PFD and Charge Pump Window 

Clicking Click for Details in the PFD & Charge Pump box of 
the main window accesses the PFD and Charge Pump window 
(see Figure 10). 
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Figure 10. PFD and Charge Pump Window 

VCO Control Window 

Clicking Click for Details in the VCO box of the main window 
accesses the VCO Control window (see Figure 11). 
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Figure 11. VCO Control Window 

Feedback Window 

Clicking Click for Details in the Feedback Divider box of the 
main window accesses the Feedback window, which allows you 
to change the feedback divider settings (see Figure 12). 
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Figure 12. Feedback Window 

P0, P1, and P2 (Output Dividers) Boxes 

Selecting the SPI check box in any of the divider settings boxes 
(that is, the P0, P1, or P2 box) in the main window enables a 
drop-down selection of predetermined divider settings (see 
Figure 13). 
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Figure 13. P0, P1, and P2 Boxes (in Main Window) 

Output Loop Config: Box 

The Output Loop Config: box can be used to change the output 
frequency of the AD9552. This control changes the logic levels 
of the output frequency selection pins of the AD9552 (see 
Figure 14). 
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Figure 14. Output Loop Config: Box (in Main Window) 

OutSel Pin: Box 

The OutSel Pin: drop-down box (see Figure 15) in the main 
window controls the logic level on the OUTSEL pin of the 
AD9552. However, this value can be overwritten by using the 
SPI control register. 
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Figure 15. OutSel Pin Box (in Main Window) 
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USING SOFTWARE TO CALCULATE THE DEVICE 
SETTINGS 
The following procedure explains how the evaluation board 
software can be used to automatically calculate and set the 
settings to program the AD9552.  

In this example, the crystal frequency is 26 MHz, and the 
output frequency is 122.88 MHz. 

1. Ensure that Jumper JMP3 is positioned for PC control. 

2. Verify that all five jumpers are in place on Connector P2. 

3. Set the positions of the S1, S2, and S3 dip switches to high. 

4. Click Calculate Device Settings in the main window of the 
evaluation board software.  
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Figure 16. Calculate Device Settings Button (in Main Window) 

5. The Enable Control? window, shown in Figure 17, 
appears.  
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Figure 17. AD9552 Serial Port Programming Warning 

6. Click Yes to enable serial port register programming.  

7. The Calculator window, shown in Figure 18, appears. 
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Figure 18. Calculator Window 

8. Type 26 into the Ref Frequency: box and 122.88 into the 
Output 1 Base Frequency: box. 

9. Click Calculate Settings. Because the AD9552 is designed 
for flexibility, there is more than one possible divider 
settings to achieve the same output frequency. Click Select 
From List, located at the top of the Output Settings box 
(see Figure 18). This generates all possible solutions. The 
user should click each solution and try to determine which 
has lowest spur for example. 
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Figure 19. Calculator Window List 

10. Click Apply Settings. You should now be able to measure 
122.88 MHz at the OUT1 SMA connector. 

ROUTING 26 MHz TO TEST PORT 
The following procedure explains how to route the 26 MHz 
crystal oscillator to the AD9552 test port. The test port is SMA 
J7 and is labeled output PLL locked. 

In this example, the crystal frequency is 26 MHz, and the 
output frequency is 122.88 MHz. 

1. Ensure that Jumper JMP3 is positioned for PC control. 

2. Verify that all five jumpers are in place on Connector P2. 

3. Set the positions of the S1, S2, and S3 dip switches to high. 

4. Click Calculate Device Settings in the main window of the 
evaluation board software.  
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Figure 20. Calculate Device Settings Button (in Main Window) 

5. The Enable Control? window, shown in Figure 21, 
appears.  
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9. Click Calculate Settings, and then click Apply Settings. 
You should now be able to measure 122.88 MHz at the 
OUT1 SMA connector. 
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10. From the View menu in the main window, select Register 
Debug Window. The window shown in Figure 23 appears. 
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Figure 21. AD9552 Serial Port Programming Warning 

6. Click Yes to enable serial port register programming. 

7. The Calculator window, shown in Figure 22, appears. 
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Figure 23. Register Debug Window 

11. Bit 3 of Register 0x17 must be set to 1 to enable the PLL 
locked pin as a test port. By default, the 26 MHz crystal 
frequency is present at the output. 

12. The ac signal has a dc offset of approximately 1.6 V. Be 
aware that some test equipment has a limit of 0 V dc; 
therefore, a dc block must be used in such cases. 

Figure 22. Calculator Window 

8. Type 26 into the Ref Frequency: box and 122.88 into the 
Output 1 Base Frequency: box.  
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NOTES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ESD CAUTION 

 
 

 
Evaluation boards are only intended for device evaluation and not for production purposes. Evaluation boards are supplied “as is” and without warranties of any kind, express, 
implied, or statutory including, but not limited to, any implied warranty of merchantability or fitness for a particular purpose. No license is granted by implication or otherwise under 
any patents or other intellectual property by application or use of evaluation boards. Information furnished by Analog Devices is believed to be accurate and reliable. However, no 
responsibility is assumed by Analog Devices for its use, nor for any infringements of patents or other rights of third parties that may result from its use. Analog Devices reserves the 
right to change devices or specifications at any time without notice. Trademarks and registered trademarks are the property of their respective owners. Evaluation boards are not 
authorized to be used in life support devices or systems. 

©2010 Analog Devices, Inc. All rights reserved. Trademarks and  
 registered trademarks are the property of their respective owners. 
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